Can’t install gulp.js or update npm past version 1.2.32

My problem started with not being able to install gulp. I checked my npm version (npm --version ) and saw I have version 1.2.32 whilst the time of this writing the newest version was 1.4.3. After countless trying of commands like

npm cache clean
npm update -g npm
npm update
npm install gulp -g

and reinstalling Node.js from official site I realized that even though I removed my Node.js installation from C:\Program Files\nodejs  I still had it in C:\Program Files (x86). Doh! :/ So, after I removed both installations, I redownloaded the exe file from Nodejs.org and installed to C:\nodejs. After this, when I ran npm install gulp everything went well. However, when I tried to install it globally (npm install gulp -g ) I got:

npm ERR! peerinvalid The package generator-karma does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer [email protected] wants [email protected]~0.6.0
npm ERR! peerinvalid Peer [email protected] wants [email protected]>=0.6.0

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "gulp-util" "-g"
npm ERR! cwd C:\Users\Nikola\Desktop\skeleton
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.3
npm ERR! code EPEERINVALID
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     C:\Users\Nikola\Desktop\skeleton\npm-debug.log
npm ERR! not ok code 0

Then I uninstalled npm uninstall -g generator-karma and npm uninstall -g generator-angular , and gulp installed fine.

 

Written by Nikola Brežnjak